A quick trick to upgrade the javascript dependencies in your project.

Use the command $ yarn upgrade-interactive

It will show you an interface to select the packages you want to upgrade. The packages listed in red would be upgraded when you would execute the $ yarn upgrade command. Yellow packages are semver incompatible, meaning that they may be incompatible with your code. Extra caution is needed when upgrading those.

You can use space to select the packages, press enter to install them.

See: https://yarnpkg.com/lang/en/docs/cli/upgrade-interactive/